
<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="no-js lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="no-js lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="no-js lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<!-- metas -->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Five to Try: Check out this week&#039;s hottest Android games and apps</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="canonical" href="http://www.greenbot.com/article/3204907/android/five-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html"/>
<meta itemprop="url" content="http://www.greenbot.com/article/3204907/android/five-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html"/>
<meta name="description" content="Check out this week&#039;s most enticing (and entertaining) Android app releases."/>
<meta name="news_keywords" content="new Android apps,best new Android apps,new Android games,Silicon Valley,Futurama,Adidas,Twitch"/>
<meta name="DC.date.issued" content="2017-06-30T04:00-05:00"/>
<meta name="date" content="2017-06-30"/>
<link rel="amphtml" href="http://www.greenbot.com/article/3204907/android/five-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.amp.html"/>
<meta property="og:title" content="Five to Try: Check out this week&#039;s hottest Android games and apps">
<meta property="og:image" content="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-lead-100727721-large.3x2.jpg"/>
<meta property="og:image:width" content="700"/>
<meta property="og:image:height" content="467"/>
<meta itemprop="image" content="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-lead-100727721-large.3x2.jpg">
<meta itemprop="thumbnailURl" content="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-lead-100727721-large.3x2.jpg"/>
<link rel="image_src" href="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-lead-100727721-large.3x2.jpg"/>
<meta name="twitter:image" content="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-lead-100727721-large.3x2.jpg"/>
<meta property="og:type" content="article"/>
<meta name="author" content="Andrew Hayward">
<meta property="og:site_name" content="Greenbot"/>
<meta property="og:url" content="http://www.greenbot.com/article/3204907/android/five-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html">
<meta name="twitter:url" content="http://www.greenbot.com/article/3204907/android/five-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html">
<!-- Add to article pages only -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@agreenbot">
<meta property="og:description" content="Check out this week&#039;s most enticing (and entertaining) Android app releases.">
<meta name="twitter:description" content="Check out this week&#039;s most enticing (and entertaining) Android app releases.">
<meta name="rating" content="General">
<meta name="robots" content="NOODP,NOYDIR"/>
<meta name="google-site-verification" content="RsuMNV5JAoG4IpkzPq3MzrklhiMbaLHkUDrcAly27cU"/>
<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3"/>
<!-- Sailthru -->
<meta name="sailthru.tags" content="android,apps,software-games,android-nougat,andrew-hayward,five-to-try,feature,medium"/>
<meta name="sailthru.image.thumb" content="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-lead-100727721-small.jpg"/>
<meta name="sailthru.image.full" content="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-lead-100727721-large.3x2.jpg"/>
<meta name="displaytype" content="article"/>
<meta name="blogs" content="five to try"/>
<meta name="source" content="greenbot"/>
<meta name="category" content="android,mobile apps,games"/>
<meta name="storytype" content="feature"/>
<meta name="tags" content="android nougat"/>
<!-- pagination -->
<style>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</style>
<!-- css -->
<link rel="stylesheet" href="/www.idge/css/normalize.css?v=20170629113016"/>
<link rel="stylesheet" href="/www.idge/css/prettify.css?v=20170629113016"/>
<link rel="stylesheet" href="/www.idge/css/article.css?v=20170629113016"/>
<link rel="stylesheet" href="/www.idge/css/print.css?v=20170629113016" media="print"/>
<link rel="stylesheet" href="/www.idge.grb/css/article.css?v=20170629113016"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css?v=20170629113016"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css?v=20170629113016"/>
<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->
<script type="text/javascript" src="http://fonts.staticworld.net/fuq4mke.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
<!--  fav and touch icons -->
<link rel="shortcut icon" type="image/x-icon" href="/www.idge.grb/favicon.ico"/>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://idge.staticworld.net/grb/greenbot-logo-144x144.gif"/>
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="http://idge.staticworld.net/grb/greenbot-logo-114x114.gif"/>
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="http://idge.staticworld.net/grb/greenbot-logo-72x72.gif"/>
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="http://idge.staticworld.net/grb/greenbot-logo-57x57.gif"/>
<link rel="apple-touch-icon" href="http://idge.staticworld.net/grb/greenbot-logo-300x300.png"/>
<!-- js -->
<script src="/www.idge/js/jquery/jquery-1.10.2.min.js"></script>
<script src="/www/js/init_device.js?v=20170629113016"></script>
<!-- google_dfp needs jquery defined first -->
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20170629113016"></script>
<script type="text/javascript">if(adLayer==null||adLayer=='undefined'){var adLayer=[];}adLayer["itemType"]="article";</script>
<script src="/www/js/ads/narf_prebid.js?v=20170629113016"></script>
<!-- LiveRamp Sources -->
<script type="text/javascript" src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
<script src="/www/js/utils/liveRamp.js?v=20170629113016"></script>
<!-- End of LiveRamp -->
<script type="text/javascript">try{IDG.GPT.unitName="/8456/IDG.US_CSMB_Greenbot.com";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.unitName=IDG.GPT.unitName+"/"+"android_section";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}var global_ShowSuper=true;var global_ShowHero=false;var url=window.location.href;if(url.indexOf("?")>1){url=url.split('?')[0];}try{IDG.GPT.addTarget("URL",encodeURIComponent(url));}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("zone",'article-blog/android');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("blogId",'1412');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("articleId",'3204907');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("type",'feature');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("typeId",'6');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("templateType",'article-default');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categoryIds",[3145,3387,3084]);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categorySlugs",['android','apps','software-games']);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{if(null!=IDG.GPT.getQsVal("env")){IDG.GPT.addTarget("env",IDG.GPT.getQsVal("env").replace(/\W/g,""));}}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("author",'Andrew Hayward');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("page_type",'');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("blog_name",'Five to Try');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("tagNames",'Android Nougat');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("insiderContent",'false');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}</script>
<script type="text/javascript" src="/www/js/ads/proximic.js?v=20170629113016"></script>
<script type="text/javascript">console.log("PROXIMIC RESPONSE: SITE-LEVEL");var currentUrl='http://www.greenbot.com/article/3204907/android/five-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html';(function(u){var f="scr";var e=(u?("url="+u):"");document.write("<"+f+"ipt type='text/javascript' src='http://t.zqtk.net/c.js?m=1&s=idg_js&"+e.replace(/\'/g,"")+"'></"+f+"ipt>");})((typeof(currentUrl)==="undefined")?"":currentUrl);</script>
<script type="text/javascript"></script>
<script src="/www.idge/js/thm_pre.js?v=20170629113016"></script>
<script type="text/javascript">$thm.useBusinessData=true;</script>
<script>var isMobile=(typeof IDG.DEVICE!=='undefined')?IDG.DEVICE.isMobile():false;try{IDG.GPT.addBiddingParams("yieldbotPsn",(isMobile?"3e2e":"07cf"));IDG.GPT.addBiddingParams("appnexusPlacementId",(isMobile?"6451029":"6352838"));}catch(e){console.log("Error in adding bidding params: "+e);}</script>
<script type="text/javascript" src="/www/js/ads/prebid_gpt_launcher.js?v=20170629113016"></script>
<!-- All JavaScript at the bottom, except for Modernizr which enables HTML5 elements & feature detects -->
<script src="/www.idge/js/mule/modernizr.js?v=20170629113016"></script>
<script type="text/javascript">var g_arrModules=new Array();</script>
<meta name="parsely-title" content="Five to Try: Not Hotdog is a perfect July 4th gag app, and Futurama: World of Tomorrow opens up"/>
<meta name="parsely-link" content="http://www.greenbot.com/article/3204907/android/five-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html"/>
<meta name="parsely-type" content="NewsArticle"/>
<meta name="parsely-image-url" content="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-lead-100727721-large.3x2.jpg"/>
<meta name="parsely-pub-date" content="2017-06-30T11:00:00Z"/>
<meta name="parsely-section" content="Android"/>
<meta name="parsely-author" content="Andrew Hayward"/>
<meta name="parsely-tags" content="Android Nougat,blog: Five to Try,type: feature,source: greenbot,original"/>
<script src="http://a.postrelease.com/serve/load.js?async=true"></script>
<script>dataLayer=[{'primaryCategory':'Android','ga_enabled':'true','articleType':'Feature','articleId':'3204907','articleTitle':'Five to Try: Not Hotdog is a perfect July 4th gag app, and Futurama: World of Tomorrow opens up','blogName':'Five to Try','parselyEnabled':'true','parselyDomain':'greenbot.com','viglinksId':'9c613cefce661f6f09ae23063b5e82ab','geolocEnabled':'true'}];</script>
<script type="text/javascript">var _sf_async_config={};_sf_async_config.uid=29363;_sf_async_config.path="/article/3204907/android/five-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html";_sf_async_config.title="Five to Try: Check out this week\&#039;s hottest Android games and apps";_sf_async_config.domain="greenbot.com";if(window.location.href.indexOf("video")&&true){_sf_async_config.playerdomain=_sf_async_config.domain.replace("www.","");}_sf_async_config.useCanonical=true;_sf_async_config.sections="android";_sf_async_config.authors="Andrew Hayward";</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-TM76KR" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-TM76KR');</script>
<!-- End Google Tag Manager -->
</head>
<body id="article3204907" class="article blog1412 greenbot">
<!-- Begin welcome ad overlay - gpt-overlay position  -->
<div id="superadunit" class="hidden">
<div class="ad">
<a href="javascript:unhide('superadunit');" id="superstitial-text">This ad will close in 20 seconds. Continue to site &raquo;</a>
<div id="gpt-overlay" class=" ad-container">
<script type="text/javascript">var appealSeenCookie;try{appealSeenCookie=readCookie('appealSeen');}catch(err){"Error: appealSeenCookie: "+err;}var blockerCookie;try{blockerCookie=readCookie('converted');}catch(err){"Error: blockerCookie: "+err;}if(((blockerCookie!=''&&JSON.parse(readCookie('converted')).convert))||(appealSeenCookie!=''&&appealSeenCookie)){}else{IDG.GPT.addDisplayedAd("gpt-overlay","true");IDG.GPT.displayGoogleTagSlot('gpt-overlay');}</script>
</div>
</div>
</div>
<!--  End welcome ad overlay - gpt-overlay position -->
<!-- BEGIN PAGE HEADER -->
<header id="banner">
<div class="main-header">
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.main-header').insertBefore($('#banner .ad'));}</script>
<div class="topics-wrap">
<section class="topics">
<nav id="scrollable">
</nav>
<div class="fading-gradient"></div>
</section>
</div>
<section id="" class="main">
<div class="wrapper">
<div class="masthead">
<button><i class="ss-icon ss-rows"></i></button>
<a href="/"><span class="ir logo">greenbot</span></a>
<!--
	            	<img class="print-only" src="/www.idge.grb/images/greenbot-logo-print.png">
	            	-->
<img class="print-only" src="http://idge.staticworld.net/grb/greenbot-logo-print.png">
</div>
<div id="reading-tools-wrapper">
<div class="reading">
<div id="reading-selector">
<div class="label">Popular Stories<span class="colon">:</span> <i class="ss-icon ss-dropdown tick"></i></div>
<ul>
<li><a href="/article/2359684/a-list-of-all-the-ok-google-voice-commands.html">A list of all the Google Now voice commands</a></li>
<li><a href="/article/2144800/13-tips-and-tricks-to-master-your-htc-one-m8.html">13 tips and tricks to master your HTC One (M8)</a></li>
<li><a href="/article/2456288/11-simple-tips-and-tricks-to-get-more-from-your-lg-g3.html">11 simple tips and tricks to get more from your LG G3</a></li>
<li><a href="/article/2142705/16-tips-to-get-the-most-from-your-samsung-galaxy-s5.html">Get the most from your Samsung Galaxy S5 with these 16 tips and tricks</a></li>
<li><a href="/article/2151010/back-that-app-up-5-great-backup-utilities-for-android.html">Back that app up: 5 great backup utilities for Android</a></li>
<li><a href="/article/2455974/cabin-review-track-your-familys-location-send-messages-and-assign-tasks.html">Cabin review: Track your family&#039;s location, send messages, and assign tasks</a></li>
</ul>
</div>
</div>
<nav class="tools">
<ul class="social">
<li><a href="https://twitter.com/agreenbot" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="https://www.facebook.com/agreenbot" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/b/111839057318649339420/" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
</ul>
<ul class="user">
<li><a href="#search" id="search-btn"><i class="ss-icon">Search</i></a></li>
</ul>
</nav>
</div>
</div>
</section>
<section class="tools-expand  ">
<form class="search" id="search-form" action="/search">
<label for="search-box">Search for</label>
<input type="text" name="query" id="banner-search-term" value="" class="searchbox-input-class"/>
<input type="submit" id="banner-search-submit" value="Go"/>
<input type="hidden" name="contentType" value="article,resource"/>
<div class="search-suggest">Suggestions for you</div>
</form>
<div class="user">
<form>
<label for="login-email">Insider email</label> <input id="login-email" type="text"/>
</form>
</div>
</section>
<nav id="" class="main">
<ul class="primary">
<li><a href="/category/apps/" class="hasChildren">Apps<span class="ss-icon ss-navigateright"></span></a>
<ul class="">
<li><a href="/category/apps/">All Apps</a></li>
<li><a href="/category/software-entertainment/">Entertainment Software</a></li>
<li><a href="/category/software-games/">Games</a></li>
<li><a href="/category/software-productivity/">Productivity Software</a></li>
<li><a href="/category/social-media/">Social Media</a></li>
<li><a href="/category/software-utilities/">Utility Software</a></li>
</ul>
</li>
<li><a href="/category/gadgets/">Gadgets</a>
</li>
<li><a href="/category/google-services/" class="hasChildren">Google Services<span class="ss-icon ss-navigateright"></span></a>
<ul class="">
<li><a href="/category/google-services/">All Google Services</a></li>
<li><a href="/category/google-apps/">Google Apps</a></li>
</ul>
</li>
<li><a href="/category/carriers/">Mobile Carriers</a>
</li>
<li><a href="/category/smartphones/">Phones</a>
</li>
<li><a href="/resources/">Resources</a>
</li>
<li><a href="/category/tablets/">Tablets</a>
</li>
<li><a href="/category/tech-events/" class="hasChildren">Tech Events<span class="ss-icon ss-navigateright"></span></a>
<ul class="">
<li><a href="/category/tech-events/">All Tech Events</a></li>
<li><a href="/category/back-to-school/">Back to School</a></li>
<li><a href="/category/holiday/">Holiday Gift Guide</a></li>
</ul>
</li>
</ul>
<ul class="secondary">
<li><a href="/news/">News</a></li>
<li><a href="/tips/">Tips</a></li>
<li><a href="/about/submit-tip.html">Submit a tip</a></li>
</ul>
</nav>
</div>
</header>
<!-- END PAGE HEADER -->
<div id="page-wrapper" class="page-wrapper">
<div id="skinAdTarget"></div>
<section role="main">
<article itemscope itemtype="http://schema.org/BlogPosting" class="blog">
<div class="ticker-ad ad">
<div id="ticker" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("ticker","true");$('#ticker').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: ticker - [971 1115]");</script>
</div>
<!-- Events Header -->
<!-- //end Events Header -->
<header class='cat'>
<nav class="breadcrumbs horiz">
<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
<li><a href="/category/android/" itemprop="url"><span itemprop="title">Android</span></a></li>
</ul>
</nav>
<div class="blog-byline vcard author with-image" itemscope itemtype="http://schema.org/Person" itemprop="author">
<div class="brand ">
<a href="/author/Andrew-Hayward/" rel="author" title="Andrew Hayward"><img class="bylineImage  imgId100267280 " src="http://core1.staticworld.net/images/article/2014/05/ah-100267280-byline.png" width="34" width="34" alt="Andrew Hayward" itemprop="image"/></a>
<div class="blog-branding-text">
<div class="blog-title"><a href="/blog/five-to-try/">Five to Try</a></div>
<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
By <span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Andrew-Hayward/"><span itemprop="name">Andrew Hayward</span></a></span>,
<span class="cn-container">
</span>
Contributor,
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">Greenbot</span></span>
<span class="divider break">|</span>
<span class="pub-date" class='break-date' itemprop="datePublished" content="2017-06-30T04:00-0700">Jun 30, 2017 4:00 AM
PT
</span>
</p>
</div>
</div>
<div class="about">
<div class="about-title">About <span class="divider">|</span> <a href="/blog/five-to-try/index.rss"><i class="ss-icon ss-social ss-rss"></i></a></div>
<p>Each week, we highlight five apps or games worth taking the time to download.</p>
</div>
</div>
<div class="category"><a href="/feature" itemprop="genre">Feature</a></div>
<h1 itemprop="headline">Five to Try: Not Hotdog is a perfect July 4th gag app, and Futurama: World of Tomorrow opens up</h1>
<section class="deck viewability">
<h2 itemprop="description">Check out this week's most enticing (and entertaining) Android app releases.</h2>
</section>
<div class="cat-social">
<div id="sharer" class="cat sidecar show blog">
<ul id="share-tool" class="expand">
<li class="sosh">
<a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.greenbot.com%2Farticle%2F3204907%2Fandroid%2Ffive-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html&via=agreenbot&text=Five+to+Try%3A+Not+Hotdog+is+a+perfect+July+4th+gag+app%2C+and+Futurama%3A+World+of" target="_blank" onclick="sharingTrack('Twitter-vert', 'twshare')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/twitter.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.greenbot.com%2Farticle%2F3204907%2Fandroid%2Ffive-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html" target="_blank" onclick="sharingTrack('Facebook-vert', 'fblike')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/facebook.svg"/>
</a>
</li>
<li class="sosh">
<a href="http://www.linkedin.com/shareArticle?url=http%3A%2F%2Fwww.greenbot.com%2Farticle%2F3204907%2Fandroid%2Ffive-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html&title=Five+to+Try%3A+Not+Hotdog+is+a+perfect+July+4th+gag+app%2C+and+Futurama%3A+World+of" target="_blank" onclick="sharingTrack('LinkedIn-vert')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/linkedin.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.greenbot.com%2Farticle%2F3204907%2Fandroid%2Ffive-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html" target="_blank" onclick="sharingTrack('GooglePlus-vert', 'googplus')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/gplus.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://reddit.com/submit?url=http%3A%2F%2Fwww.greenbot.com%2Farticle%2F3204907%2Fandroid%2Ffive-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html&title=Five+to+Try%3A+Not+Hotdog+is+a+perfect+July+4th+gag+app%2C+and+Futurama%3A+World+of" target="_blank" onclick="sharingTrack('Reddit-vert')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/reddit.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.greenbot.com%2Farticle%2F3204907%2Fandroid%2Ffive-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html" target="_blank" onclick="sharingTrack('ShareStumbleupPrint-vert')">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/stumbleupon.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="#email" id="email-icon">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/mail.svg"/>
</a>
</li>
<li class="sosh hide print">
<a href="javascript:window.print();">
<img class="sidecar-icon" src="http://idge.staticworld.net/images/print.svg"/>
</a>
</li>
<li class="more">
<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
</li>
</ul>
</div>
<script type="text/javascript">var isValidEmailAddress=isValidEmailAddress||function(emailAddress){var pattern=new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);return pattern.test(emailAddress);};function encodeQueryData(params){var ret=[];for(var paramKey in params){ret.push(encodeURIComponent(paramKey)+"="+encodeURIComponent(params[paramKey]));}return ret.join("&");}function bindEmailModal(){$('#emailModal').on("click",".close-btn",function(event){event.preventDefault();$('#emailModal').hide();$("#emailModal .eml-friend").show();$(".eml-friend-success").hide();$(".eml-friend-error").hide();$('#emailModal').fadeOut(200);$('#email-to').val('');$('#email-from').val('');$('#name').val('');$('#personalization').val('');$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");});$('#emailModal').on("submit","form",function(event){event.preventDefault();var $form=$(this);var action=$form.attr('action');var formData=$form.serialize();var emailFrom=$('#email-from').val();var emailTo=$('#email-to').val();var uresponse=$('#g-recaptcha-response').val();$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");if(isValidEmailAddress(emailFrom)&&isValidEmailAddress(emailTo)&&uresponse!=""){$.ajax(action,{type:'POST',data:formData,success:function(data,textStatus,xhr){$("#emailModal .eml-friend").hide();$(".eml-friend-success").fadeIn(800);},error:function(xhr,textStatus,errorThrown){$("#emailModal .eml-friend").hide();$(".eml-friend-error").fadeIn(800);}});}else{if(uresponse==""){$('#eml-friend-captcha-message').html("Please verify you're not a robot!");}if(!isValidEmailAddress(emailTo)){$('#eml-to-address-message').html("Please enter a valid email address.");}if(!isValidEmailAddress(emailFrom)){$('#eml-from-address-message').html("Please enter a valid email address.");}}});}$(document).ready(function(){$(document).on("click","#email-icon",function(event){event.preventDefault();bindEmailModal();sharingTrack('Email-vert');$('#emailModal').fadeIn(800);});});</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">
<form class="eml-friend" action="/eloquaemail/article?eloqua=false&id=3204907">
<input type="hidden" name="title" value="Five to Try: Not Hotdog is a perfect July 4th gag app, and Futurama: World of Tomorrow opens up"/>
<input type="hidden" name="url" value="http://www.greenbot.com/article/3204907/android/five-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html"/>
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Email a friend</h3>
<div class="input-row">
<div id="eml-to-address-message" class="error-msg"></div>
<h4 class="input-label">To</h4>
<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
<p class="addl-text">Use commas to separate multiple email addresses</p>
</div>
<hr/>
<div class="input-row">
<div id="eml-from-address-message" class="error-msg"></div>
<h4 class="input-label">From</h4>
<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
</div>
<div class="input-row">
<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
</div>
<div class="input-row">
<textarea name="message" placeholder="Check out this article I found on Greenbot." id="personalization" tabindex="4"></textarea>
</div>
<hr/>
<div class="input-row">
<div id="eml-friend-captcha-message" class="error-msg"></div>
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
<div class="g-recaptcha" data-sitekey="6LdPbfsSAAAAAB89GpzHsyYe-AGzZXYy9K_4KAnF"></div>
</div>
<hr/>
<div class="submit">
<input type="submit" value="Send" class="input-submit" tabindex="5">
<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
</div>
</form>
<div class="eml-ty eml-friend-success" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Thank you</h3>
<p class="msg-sent">Your message has been sent.</p>
</div>
<div class="eml-friend-error" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Sorry</h3>
<p class="msg-sent">There was an error emailing this page.</p>
</div>
</div>
</div>
<div class="ad viewability">
<div id="topleaderboard" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("topleaderboard","true");$('#topleaderboard').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");</script>
</div>
</header>
<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
<meta itemprop="representativeOfPage" content="1">
<img src="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-lead-100727721-large.jpg" alt="fivetotry june30 lead" itemprop="contentUrl"/>
<figcaption>
Credit:<span itemprop="copyrightHolder">
Andrew Hayward/IDG
</span>
</figcaption>
</figure>
<section class="epo cat-narrow" id="drr-top-ad">
<!-- Related -->
<div class="related-promo-wrapper">
<div class="promo apart">
<div class="hed">More like this</div>
<ul class="">
<li class="clearfix with-image">
<a href="/article/3190172/android/galaxy-s8-review-the-future-of-android-is-now.html"><img class="small.3x2Image  imgId100718363 " src="http://core0.staticworld.net/images/article/2017/04/galaxy-s8-full-100718363-small.3x2.jpg" alt="galaxy s8 full" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3190172/android/galaxy-s8-review-the-future-of-android-is-now.html">Galaxy S8+ review: The future of Android is now</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3198481/android/huawei-watch-2-classic-review-another-missed-opportunity-for-android-wear-2-0.html"><img class="small.3x2Image  imgId100723964 " src="http://images.idgesg.net/images/article/2017/05/huawei-watch2-battery-100723964-small.3x2.jpg" alt="huawei watch2 battery" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3198481/android/huawei-watch-2-classic-review-another-missed-opportunity-for-android-wear-2-0.html">Huawei Watch 2 Classic Review: Good watch but a missed opportunity for Wear 2.0</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3190642/android/samsung-galaxy-s8-review-the-best-phone-ever-made-only-smaller.html"><img class="small.3x2Image  imgId100718697 " src="http://core5.staticworld.net/images/article/2017/04/galaxy-s8-primary2-100718697-small.3x2.jpg" alt="galaxy s8 primary2" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3190642/android/samsung-galaxy-s8-review-the-best-phone-ever-made-only-smaller.html">Samsung Galaxy S8 review: The best phone ever made, only smaller</a></div>
</div>
</li>
<li class="clearfix with-image">
<a class="play" href="/video/77835/hands-on-with-the-new-google-assistant"><i class="ss-play"></i></a>
<a href="/video/77835/hands-on-with-the-new-google-assistant"><img class="small.3x2Image  imgId100723067 " src="http://core0.staticworld.net/images/article/2017/05/dsc05160-100723067-small.3x2.jpg" alt="dsc05160" itemprop="image"/></a>
<div class="item">
<div class="item-eyebrow">Video</div>
<div class="title"><a href="/video/77835/hands-on-with-the-new-google-assistant">Hands-on with the new Google Assistant.</a></div>
</div>
</li>
</ul>
</div>
</div>
<div class="ad top-ad">
<div id="topimu" class="adunit ad-container">
</div>
<script type="text/javascript">if($(window).width()>=930){IDG.GPT.addDisplayedAd("topimu","true");$('#topimu').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topimu - [971 1115]");}</script>
</div>
</section>
<section class="bodee">
<div class="ad placement">
<!--  Begin gpt-skin/inread -->
<div id="inread" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("inread","true");IDG.GPT.displayGoogleTagSlot('inread');</script>
<!--  End gpt-skin/inread -->
</div>
<script type="text/javascript">$(document).ready(function(){$('.articleBloxAd').filter(":visible").each(function(index,item){var id=$(item).attr('id');var divClass=$(item).attr('class');var adString=IDG.GPT.getLazyAdCode();$(item).replaceWith("<div id=\""+id+"\" class=\"lazyload_blox_ad "+divClass+"\">"+adString+"</div>");});try{$("div.lazyload_blox_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("error loading lazyload_ad "+exception);}});</script>
<script type="text/javascript">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</script>
<div id="drr-container" class='cat ' itemprop="articleBody">
<p>We’re only a few days away from the Fourth of July, and if you plan to celebrate Independence Day at a party with pals, then you might want to grab HBO’s Not Hotdog app. You don’t have to be a fan of <em>Silicon Valley</em> to appreciate this neural network-powered gag, which manages to be both weirdly brilliant and impressively pointless. </p><p>On the other hand, if you’re looking for something a bit more useful, then Adidas’ new All Day fitness and health app might help you stay on track amidst holiday shenanigans. And if you just want to have fun on your Android device, then <em>Futurama: World of Tomorrow</em> and <em>Oxenfree</em> are both worth a look, along with the feature-boosting new Twitch update. </p><h2><strong><a href="https://play.google.com/store/apps/details?id=com.seefoodtechnologies.nothotdog">Not Hotdog</a></strong></h2><figure class="large "><img src="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-nothotdog-100727725-large.jpg" border="0" alt="fivetotry june30 nothotdog" width="700" height="714" data-imageid="100727725" data-license="IDG"/> <small class="credit">IDG</small> <figcaption>
<p>I didn't have a real hot dog handy, but the app still nailed it.</p>
</figcaption></figure><p>Are you having trouble determining if an item is a hot dog… or <em>not</em> a hot dog? This uncommon conundrum could derail a meal, let alone your entire day, but finally there’s a solution: Not Hotdog. This app lets you snap a photo or pull an image from your camera roll, and then it uses the power of a neural network to determine whether what’s pictured is a hot dog or not.</p><p>Yes, it’s obviously a joke app—and yet it’s a surprisingly complex one. Not Hotdog is based on a storyline from this season of HBO’s <em>Silicon Valley</em> (<a href="https://www.youtube.com/watch?v=ACmydtFDTGs">here’s the relevant, NSFW clip</a>), which has been turned into a fully functional app that uses AI to determine what’s being shown. In fact, <a href="https://hackernoon.com/how-hbos-silicon-valley-built-not-hotdog-with-mobile-tensorflow-keras-react-native-ef03260747f3">here’s an incredibly extensive article</a> about how it was made. Not Hotdog’s limited functionality means it probably won’t become Shazam for food, but it might crack up some pals at your next BBQ.</p><aside class="nativo-promo smartphone" id=""> </aside><h2><strong><a href="https://play.google.com/store/apps/details?id=com.tinyco.futurama&amp;hl=en">Futurama: World of Tomorrow</a></strong></h2><figure class="large "><img src="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-futurama-100727722-large.jpg" border="0" alt="fivetotry june30 futurama" width="700" height="394" data-imageid="100727722" data-license="IDG"/> <small class="credit">IDG</small> <figcaption>
<p>Gradually fill your world with <em>Futurama</em> nonsense.</p>
</figcaption></figure><p><em>Futurama</em> may be done as a TV show, but the franchise lives on in the world of mobile games. After last year’s very solid <a href="https://play.google.com/store/apps/details?id=com.wooga.futurama&amp;hl=en"><em>Game of Drones</em></a>, now we have <em>Futurama: World of Tomorrow</em>, essentially the show’s take on <a href="https://play.google.com/store/apps/details?id=com.ea.game.simpsons4_na"><em>The Simpsons: Tapped Out</em></a> and <a href="https://play.google.com/store/apps/details?id=com.tinyco.familyguy"><em>Family Guy: Quest for Stuff</em></a>. In fact, it’s developed by the same company as the latter.</p><p><em>World of Tomorrow</em> lets you build up your city of New New York with familiar landmarks and items from the show, giving you an endless amount of busywork tasks to complete in exchange for currency. But at least this game adds a bit more action in the form of battles, which shift to a retro pixel aesthetic. For the most part, it’s a familiar freemium diversion, but with new animation bits and writing from the creative team (including Matt Groening), it could be a pretty funny one, at least. </p><h2><strong><a href="https://play.google.com/store/apps/details?id=com.adidas.allday">Adidas All Day</a></strong></h2><figure class="large "><img src="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-adidasallday-100727724-large.jpg" border="0" alt="fivetotry june30 adidasallday" width="700" height="714" data-imageid="100727724" data-license="IDG"/> <small class="credit">IDG</small> <figcaption>
<p>Get (or stay) on track with Adidas All Day.</p>
</figcaption></figure><p>There’s no shortage of fitness tracking and health-boosting apps on the Play Store, but if you’re a bigger fan of Adidas’ stripes than, say, <a href="https://play.google.com/store/apps/dev?id=5943102410143165456">Nike’s swoosh</a>, then maybe All Day will grab your interest. Just launched this week, All Day is Adidas’ attempt to provide an all-in-one health and fitness hub, which can automatically track your steps and estimate burned calories, as well as let you manually track activities.</p><p>It also offers some original content for boosting other parts of your healthy lifestyle, including yoga and fitness videos, and recipe. And All Day will also send you reminders to keep you on track with exercise and eating plans. All Day’s marketing is focused on women, but anyone can benefit from this free app. </p><aside class="nativo-promo tablet desktop" id=""> </aside><h2><strong><a href="https://play.google.com/store/apps/details?id=com.NightSchool.Oxenfree">Oxenfree</a></strong></h2><figure class="large "><img src="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-oxenfree-100727723-large.jpg" border="0" alt="fivetotry june30 oxenfree" width="700" height="394" data-imageid="100727723" data-license="IDG"/> <small class="credit">IDG</small> <figcaption>
<p>Ah, teen drama… and ghosts, too.</p>
</figcaption></figure><p>Acclaimed indie quest <em>Oxenfree</em> ($5) has been gradually rolling out across platforms since last year, and now it’s on Android. If you like choose-your-own-adventure storytelling, supernatural overtones, and '80s teen movies, then you'll probably dig this tale about a group of friends who decide to have a bash on an abandoned island… with some unexpected guests.</p><p>See, Alex and her pals accidentally unlock a portal to a ghostly realm along the way, and you’ll have to solve puzzles and navigate conversations to make it out alive. You’re given a lot of control over the dialogue, which feels very fluid and authentic, and the relationships between the friends and family members can change significantly based on your actions. It’s a really neat little story game to get lost in for a while. </p><h2><strong><a href="https://play.google.com/store/apps/details?id=tv.twitch.android.app">Twitch</a></strong></h2><figure class="large "><img src="http://images.idgesg.net/images/article/2017/06/fivetotry-june30-twitch-100727726-large.jpg" border="0" alt="fivetotry june30 twitch" width="700" height="714" data-imageid="100727726" data-license="IDG"/> <small class="credit">IDG</small> <figcaption>
<p>You'd watch my IRL stream, right?</p>
</figcaption></figure><p><a href="https://www.twitch.tv/">Twitch</a> is a gaming phenomenon, as more than 100 million viewers tune in every month to watch other people play video games—whether they’re streaming high-level online play, solo campaign action, or footage from esports competitions. And now the Twitch app has become significantly more useful with the release of the 5.0 update.</p><p>The visual and navigational shift is the most obvious addition, as the app gets a makeover that splits content into three categories: Live, Pulse, and Browse. That makes it easier to follow the channels and creators you already know while also discovering new feeds. But there’s an even bigger function built in: live streaming. IRL (“in real life”) streams have been growing in popularity on Twitch, especially from established personalities, and now they (and you) will be able to share footage directly from device cameras.</p><p>The 5.0 update is rolling out now and should reach everyone in the coming days. If you're not seeing it, you can <a href="http://www.apkmirror.com/apk/twitch-interactive-inc/twitch/twitch-5-0-release/twitch-5-0-android-apk-download/">grab the signed APK file</a> from APK Mirror right now.</p>
<div class="end-note">
<!-- blx4 #2009 blox4.html  -->
</div>
</div>
<div class="apart-alt tags">
<span class="related">Related: </span>
<ul>
<li><a href="/category/android">Android</a></li>
<li><a href="/category/apps">Apps</a></li>
<li><a href="/category/software-games">Games</a></li>
<li><a href="/tag/android-nougat/" rel="nofollow">Android Nougat</a></li>
</ul>
</div>
<div class="byline vcard author end-byline">
<div class="author-info">
<p class="bio">Andrew Hayward is a Chicago-based games, apps, and gadgets writer whose work has been featured in more than 70 publications. He's also a work-at-home dad to an unruly four-year-old.</p>
</div><!-- end .author-info -->
<div class="brand-social">
<div class="follow-text">Follow</div>
<ul class="social-links">
<li>
<a href="/author/Andrew-Hayward/">
<i class="ss-icon ss-user"></i>
</a>
</li>
<li>
<a href="mailto:haywarda@gmail.com">
<i class="ss-icon ss-mail"></i>
</a>
</li>
<li>
<a href="https://twitter.com/ahaywa" class="twitter-follow" target="_blank">
<i class="ss-icon ss-social ss-twitter"></i>
</a>
</li>
<li>
<a href="/author/Andrew-Hayward/index.rss" class="rss">
<i class="ss-icon ss-social ss-rss"></i>
</a>
</li>
</ul>
</div>
</div>
<script src="/www/js/video/embedder.js?v=20170629113016"></script>
</section><!-- /.bodee -->
<div id="content-recommender" class="nolinks norewrite">
<div class="head">You Might Like</div>
<div id="rcjsload_26d3e4"></div>
<script type="text/javascript">(function(){function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}}ad_block_test(function(is_blocked){var widget_id=30200;if(is_blocked===true){widget_id=30271;}var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);var rcel=document.createElement("script");rcel.id='rc_'+Math.floor(Math.random()*1000);rcel.type='text/javascript';rcel.src="http://trends.revcontent.com/serve.js.php?w=30200&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth||document.documentElement.clientWidth)+"&referer="+referer+'&is_blocked='+is_blocked;rcel.async=true;var rcds=document.getElementById("rcjsload_26d3e4");rcds.appendChild(rcel);});})();</script>
</div>
<div id="amazon-bottom-widget">
<div class="amzn-custom-header">Shop Tech Products at Amazon</div>
<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&storeId=httpwwwidgcsm-20&adInstanceId=194fc7b4-db8c-466c-8198-8bd05795675e"></script>
</div>
<div class="lazyload_ad">
<code type="text/javascript">
<!--
		document.write('<div id="ciu" class=" ad-container">');
		IDG.GPT.addDisplayedAd("ciu", "true");
		IDG.GPT.addLazyloadedAd("ciu", "true");
		document.write('</div>');
		
			
			
				$('#ciu').responsiveAd({screenSize:'971 1115', scriptTags: []});
			
		
		if (Object.keys(IDG.GPT.companions).length > 0) {
		IDG.GPT.refreshAd('ciu');
		}
		//-->
</code>
</div>
<section id="resources-sponsored-links">
<section class="sponsored-links">
<div class="head">Sponsored Links</div>
<ul class="first">
<li>
<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=890984456&iu=/8456/IDG.US_CSMB_PCWorld.com" onclick="moduleTrack('Sponsored Links','resources-sponsored-links component')">
Building a cloud business case? Need data to back up your cloud strategy?
</a>
</li>
</ul>
</section>
</section>
</article>
</section><!-- /role=main -->
</div><!-- /#page-wrapper -->
<footer>
<section class="brand" itemscope itemtype="http://schema.org/Organization">
<link itemprop="url" href="http://www.greenbot.com">
<a href="/"><span class="logo">Greenbot</span></a>
<span class="tagline"> </span>
<span class="follow">
<label>Follow us</label>
<ul>
<li><a href="https://twitter.com/agreenbot" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="https://www.facebook.com/agreenbot" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/b/111839057318649339420/" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
</ul>
</span>
</section>
<section class="topics">
<nav id="ft1">
<ul>
<li><a href="/category/apps/">Apps</a>
</li>
<li><a href="/category/gadgets/">Gadgets</a>
</li>
<li><a href="/category/google-services/">Google Services</a>
</li>
<li><a href="/category/carriers/">Mobile Carriers</a>
</li>
<li><a href="/category/smartphones/">Phones</a>
</li>
<li><a href="/resources/">Resources</a>
</li>
<li><a href="/category/tablets/">Tablets</a>
</li>
<li><a href="/category/tech-events/">Tech Events</a>
</li>
</ul>
</nav>
<nav id="ft2">
<ul>
<li><a href="/news">News</a></li>
<li><a href="/tips">Tips</a></li>
<li><a href="/about/submit-tip.html">Submit a tip</a></li>
<li><a href="/newsletters/index.html">Newsletters</a></li>
</ul>
</nav>
</section>
<section class="about">
<div class="wrapper">
<nav class="tertiary" id="ft3">
<ul>
<li><a href="/about/about.html">About Us</a>
<li><a href="/about/contactus.html">Contact</a>
<li><a href="/about/privacy.html">Privacy Policy</a>
<li><a href="http://idgcsmb.com/terms-of-service-agreement/" target="_blank" rel="nofollow">Terms of Service Agreement</a>
<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a>
<li><a href="/about/advertise.html">Advertising</a>
<li><a href="http://careers.idg.com/" target="_blank" rel="nofollow">Careers at IDG</a>
<li><a href="/about/sitemap.html">Site Map</a>
</ul>
</nav>
</div>
</section>
<section class="copyright">
<div class="wrapper">
<p><a href="/about/copyright.html">Copyright</a> &copy; 2017 IDG Communications, Inc.<br><span class="disclaimer">The Android robot is reproduced or modified from work created and shared by Google and used according to terms described in the <a href="http://creativecommons.org/licenses/by/3.0/us/" target="_blank" rel="nofollow">Creative Commons 3.0 Attribution License</a>. Greenbot is an independent site that is not affiliated with Google Inc.</span></p>
<div class="network">
<div id="network-selector">
<div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
<ul>
<li><a href="http://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
<li><a href="http://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
<li><a href="http://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
<li><a href="http://www.gamestar.com" target="_blank" rel="nofollow">GameStar</a></li>
<li><a href="http://www.greenbot.com" target="_blank" rel="nofollow">Greenbot</a></li>
<li><a href="http://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
<li><a href="http://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
<li><a href="http://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
<li><a href="http://www.idgknowledgehub.com" target="_blank" rel="nofollow">IDG Knowledge Hub</a></li>
<li><a href="http://www.idgtechnetwork.com" target="_blank" rel="nofollow">IDG TechNetwork</a></li>
<li><a href="http://www.idg.tv" target="_blank" rel="nofollow">IDG.TV</a></li>
<li><a href="http://www.idgventures.com" target="_blank" rel="nofollow">IDG Ventures</a></li>
<li><a href="http://www.infoworld.com" target="_blank" rel="nofollow">Infoworld</a></li>
<li><a href="http://www.itnews.com" target="_blank" rel="nofollow">IT News</a></li>
<li><a href="http://www.itwhitepapers.com" target="_blank" rel="nofollow">ITwhitepapers</a></li>
<li><a href="http://www.itworld.com" target="_blank" rel="nofollow">ITworld</a></li>
<li><a href="http://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
<li><a href="http://www.linuxworld.com" target="_blank" rel="nofollow">LinuxWorld</a></li>
<li><a href="http://www.macworld.com" target="_blank" rel="nofollow">Macworld</a></li>
<li><a href="http://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
<li><a href="http://www.pcworld.com" target="_blank" rel="nofollow">PC World</a></li>
<li><a href="http://www.techconnect.com" target="_blank" rel="nofollow">TechConnect</a></li>
<li><a href="http://www.techhive.com" target="_blank" rel="nofollow">TechHive</a></li>
</ul>
</div><!-- /#network-selector -->
</div><!-- /.network -->
</div><!-- /.wrapper -->
</section>
</footer>
<script src="/www/js/analytics/mouse_down.js?v=20170629113016"></script>
<script src="/www/js/jquery/jquery-ui.js?v=20170629113016"></script>
<script src="/www/js/jquery/jquery.dfp.min.js?v=20170629113016"></script>
<script src="/www.idge/js/mule/shortstack_nav.js?v=20170629113016"></script>
<script src="/www.idge/js/jquery/jt-scrollable.min.js?v=20170629113016"></script>
<div id="mobilewelcomead" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("mobilewelcomead","true");$('#mobilewelcomead').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");</script>
<script src="/www/js/analytics/tracking.js?v=20170629113016"></script>
<script src="/www/js/autocomplete.js?v=20170629113016"></script>
<script src="/www.idge/js/social_sidecar.js?v=20170629113016"></script>
<script src="/www/js/carousel-extend.js?v=20170629113016"></script>
<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js?v=20170629113016"></script>
<script src="/www.idge/js/article.js?v=20170629113016"></script>
<script src="/www/js/prettify.js?v=20170629113016"></script>
<script src="/www.idge/js/jquery/responsive-tables.js?v=20170629113016"></script>
<script src="/www.idge/js/jquery/jquery.tablesorter.min.js?v=20170629113016"></script>
<script>$(document).ready(function(){$("table.tablesorter").tablesorter({widgets:['zebra']});$("table.tablesorter tbody tr").hover(function(){$(this).toggleClass("selected");});$("table.tablesorter thead tr th").each(function(){if($(this).find('.ss-icon').length<1){$(this).append('<i class="ss-icon"></i>');}});});</script>
<script src="/www/js/jquery/jquery.lazyload.min.js?v=20170629113016"></script>
<script src="/www.idge/js/global.js?v=20170629113016"></script>
<script src="/www/js/webfonts/ss-social.js?v=20170629113016"></script>
<script src="/www/js/webfonts/ss-standard.js?v=20170629113016"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>
<!-- Begin BlueKai Tag -->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="http://tags.bkrtx.com/js/bk-coretag.js"></script>
<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js?v=20170629113016"></script>
<script type="text/javascript">bk_allow_multiple_calls=true;var blueKaiId=17640;var blueKaiPort=10;var brandCode="grb";var regUrl="http://regdev.idge.int/api/"
var daysToRefresh=30;var bk_debug_log=false;regUrl="http://reg.idgenterprise.com/api/";daysToRefresh=30;if(typeof(s)!='undefined'){bk_addPageCtx("pageType",(typeof(s.pageType)!='undefined')?s.pageType:'');}bk_addPageCtx("cmscatids","[3145,3387,3084]");bk_addPageCtx("cmpy","[]");bk_addPageCtx('tid','6');params=getUrlParams('phint');if(Object.keys(params).length>0){bk_addPageCtx("idg_eid",params['idg_eid']);bk_addPageCtx("newt",params['newt']);bk_addPageCtx("isnl","1");}try{IDG.bkCoreApi.start();}catch(e){bk_doJSTag(blueKaiId,blueKaiPort);if(window.console&&window.console.log){window.console.log("Error Occured While Processing Profile Siubmission")}}$('article, #slideshowCarousel').on('click','.product-list-price, .btn-amazon, .productLink',function(e){var $linkEl=$(e.target);var po=$linkEl.data('po');if($.inArray(po,['amazon','vendor','other'])>=0){if(po=='amazon'){var prCat=$linkEl.data('bkc');if(typeof prCat!='undefined'){bk_addPageCtx('event','AmazonClick'+prCat);}bk_addPageCtx('event','AmazonClickAndroid');bk_addPageCtx('event','AmazonClickApps');bk_addPageCtx('event','AmazonClickGames');}var prMfr=$linkEl.data('bkmfr');if(typeof prMfr!='undefined'){bk_addPageCtx('event','eCommerceMFR'+prMfr);}var prVndr=$linkEl.data('bkvndr');if(typeof prVndr!='undefined'){bk_addPageCtx('event','eCommerceClickVendor'+prVndr);}bk_doJSTag(34202,1);}});</script>
<!-- End BlueKai Tag -->
<div id="catfish" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("catfish","true");$('#catfish').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: catfish - [971 1115]");</script>
<!--  Begin gpt-skin/inread -->
<div id="gpt-skin" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-skin","true");IDG.GPT.displayGoogleTagSlot('gpt-skin');</script>
<!--  End gpt-skin/inread -->
<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js?v=20170629113016"></script>
<script type="text/javascript">$("div.lazyload_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});</script>
<script type='text/javascript'>g_arrModules['Article Detail:Top:Breadcrumb']=true;g_arrModules['Article Detail:Social Sharing Vertical']=true;g_arrModules['']=true;$('#resources-sponsored-links').addClass('show');</script>
<!-- Begin comScore Tag -->
<script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"6035308",c3:"",c5:"Android",c6:"Article: Feature",c15:"3204907"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el);})();</script>
<noscript>
<img src="http://b.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1"/>
</noscript>
<!-- End comScore Tag -->
<script language="JavaScript" type="text/javascript">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</script>
<!-- SiteCatalyst code version: H.26.2.
Copyright 1996-2013 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->
<script language="JavaScript" type="text/javascript" src="/www.idge/js/analytics/s_code.js?v=20170629113016"></script>
<script language="JavaScript" type="text/javascript" id="omniVars">g_sOmnitureReportSuite=typeof g_sOmnitureReportSuite!='undefined'&&g_sOmnitureReportSuite?g_sOmnitureReportSuite:"pcwmw-greenbot";s.pageName="Greenbot:article:feature:Android:3204907:Five to Try: Not Hotdog is a perfect July 4th gag app, and Futurama: World of Tomorrow opens up";s.pageType="";if(typeof omnitureChannel!='undefined'){s.channel=omnitureChannel;}s.prop1="source:greenbot";s.eVar1="D=c1";s.prop2="content type:feature";s.eVar2="D=c2";s.prop3="display type:article:feature";s.eVar3="D=c3";s.prop4="0 days";s.eVar4="D=c4";s.prop5="blog";s.prop6="";s.prop7="blogs:five to try";s.eVar7="D=c7";s.prop9="category:android";s.eVar9="D=c9";s.prop11="published:30-Jun-17";s.eVar11="D=c11";s.prop12="aid:3204907";s.eVar12="D=c12";s.prop13="";s.eVar13="D=c13";s.prop14="author:andrew hayward";s.eVar14="D=c14";s.prop15="page number:1";s.eVar15="D=c15";s.prop17="uri:/article/3204907/android/five-to-try-not-hotdog-is-a-perfect-july-4th-gag-app-and-futurama-world-of-tomorrow-opens-up.html";s.eVar17="D=c17";s.prop18="";s.eVar18="D=c18";s.prop24=getLoginStatusForOmniture();s.eVar24="D=c24";s.prop28=getTrackingToken('tk')?"tokens:"+getTrackingToken('tk'):"";s.eVar28="D=c28";s.prop37="rpn:grb:feature:greenbot:article:feature:android:3204907:five to try: not hotdog is a perfect july 4th gag app, and futurama: world of tomorrow opens up";s.eVar37="D=c37";s.prop39="";s.eVar39="D=c39";s.prop40="";try{s.prop41=IDG.GPT.getDisplayedAds(',')+','+IDG.GPT.getOtherAds(',');s.prop42=IDG.GPT.getModules(',');s.eVar42="D=c42";}catch(e){console.log("error in setting omniture vars: "+e);}s.prop53="3145";s.eVar53="D=c53";s.prop54="android,mobile apps,games";s.eVar30="D=c54";s.eVar33=s.prop55="3145,3387,3084";s.eVar33="D=c55";s.prop56="android nougat";s.eVar40="D=c56";s.prop61="";s.eVar10="D=c61";s.prop74="mobile";s.eVar58="D=c74";s.prop75="mobile-operating-systems";s.eVar60="D=c75";s.prop58="mobile:mobile-operating-systems";s.eVar59="D=c58";var sModules='';for(var i in g_arrModules){if(g_arrModules[i]&&i!=''){sModules+=i+',';}}sModules=sModules.replace(/,$/,'');s.prop42=sModules;s.eVar42="D=c42";s.events="";s.events=s.apl(s.events,'event33',',');s.eVar41="30-Jun-17";s.list3=s.prop42+","+s.eVar42;for(var p in s){if(s[p]&&p.match(/^(prop|ceVar)\d+$/)){s[p]=s[p].toLowerCase();}}s.campaign=s.getQueryParam('cid');var s_code=s.t();if(s_code)document.write(s_code)</script>
<script language="JavaScript" type="text/javascript">if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')</script><noscript><img src="http://pcworldcommunication.d2.sc.omtrdc.net/b/ss/pcwmw-greenbot/1/H.25--NS/0" height="1" width="1" border="0" alt=""/></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.26.2. -->
<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
<span id="parsely-cfg" data-parsely-site="greenbot.com"></span>
</div>
<script>(function(s,p,d){var h=d.location.protocol,i=p+"-"+s,e=d.getElementById(i),r=d.getElementById(p+"-root"),u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net":"static."+p+".com";if(e)return;e=d.createElement(s);e.id=i;e.async=true;e.src=h+"//"+u+"/p.js";r.appendChild(e);})("script","parsely",document);</script>
<!-- END Parse.ly Include: Standard -->
<script type="text/javascript">$thm.logPlEvent({"b":"grb","e":"view","t":"article","id":"3204907"});</script>
<div id="loginModal"></div>
<div id="logoffModal"></div>
<script type="text/javascript">a=top;f=self;if(a!=f){a.location=f.location;}</script>
<script type="text/javascript">(function(){function loadHorizon(){var s=document.createElement('script');s.type='text/javascript';s.async=true;s.src=location.protocol+'//ak.sail-horizon.com/horizon/v1.js';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);}loadHorizon();var oldOnLoad=window.onload;window.onload=function(){if(typeof oldOnLoad==='function'){oldOnLoad();}Sailthru.setup({domain:'horizon.greenbot.com',useStoredTags:false});};if(console!=undefined){console.log('SAIL-23 fired Horizon');}})();</script>
</body>
</html>